Forums

Post Reply
Forum Home > Echo Development > Sticky: Saridnours "One Click" Rooting tool

myka
Member
Posts: 2
I have not been able to root my kyocera echo. I downloaded the progmas on my phone As a last result I am now just downloading it from my home pc. the phone will not root the programs say they were not given permission to root. at first it said i needed busybox then I downloaded it and still nothing. PLEASE HELP ME!!!!
November 29, 2011 at 2:24 PM Flag Quote & Reply

pkxunubstr
Member
Posts: 1

what drivers do i install ??? alll???

:|

November 30, 2011 at 6:36 PM Flag Quote & Reply

Scarm10
Member
Posts: 13

About those drivers.... do i have a story for you all. my gf  "broke" my laptop while i was out of town, and while bored in the airport, saw you guys finished up the gingerbread root, i was stoked! i get into town, have to wait for the assclowns at geeksquad to give me back my laptop, which they said was unrepairable (my ass, just had to uninstall the drivers for my wifi card which was causing some BSODs) Get it back today, fixed the crashing problem, hop on the forum, DL Saridnours One click ( which if i may say THANK GOD!!!!) and come to find out all kyocera's sites are down, and theres no external repository of the drivers anywhere. So about those drivers.... Can anyone host em on their mediafire or possibly put up a torrent on Demonoid or The pirate bay? Ill be glad to seed if anyone still has those drivers laying around somewhere.... Cheers

December 1, 2011 at 4:08 AM Flag Quote & Reply

blahblah

Posts: 11

I'm an ubuntu linux user and since I didn't see anything posted yet for rooting from linux I want to throw together a rough description of what I did for any other linux users.

1) First, you need adb for linux. I got mine from the platform-tools folder in the android sdk.

2) You need adb to recognize you have your phone attached. Attach your phone to the computer with usb. Within the folder that adb is in, if you type ./adb devices and you get a line with a bunch of ???????? then you need to do this step. Otherwise if it shows a serial number you can skip this step.

For reference please see these two links

http://esausilva.com/2010/05/13/setting-up-adbusb-drivers-for-android-devices-in-linux-ubuntu/

Second post on here: http://ubuntuforums.org/showthread.php?t=1707734

Basically this is what I did:

From a terminal window type "lsusb". That should give you a line like below

Bus 002 Device 019: ID 0482:051b Kyocera Corp.

 

What you are looking for is the manufacturer id which in this case is the "0482"

Then you need to edit a file called /etc/udev/rules.d/51-android.rules (I use vi for my editor in this step)

sudo vi /etc/udev/rules.d/51-android.rules

Inside that file put:

SUBSYSTEM=="usb", SYSFS{idVendor}=="0482", MODE="0666"

Save it and then run these commands:

sudo chmod a+r /etc/udev/rules.d/51-android.rules

sudo service udev reload

./adb kill-server

./adb start-server

You can check to see if this worked by typing ./adb devices and it should now have a serial number instead of ????????.

3) Copy the following files from Saridnour's RootMe.rar file to the directory adb is in:

zergrush

Superuser.apk

 

su

busybox

4) From this point, I pretty much typed in all the lines from Saridnour's RootMe.bat file that start with adb, in order just like he has it up to and including the final reboot:

rem //////////// FINAL REBOOT ////////////

adb reboot

At that point you should be rooted. I currently am rooted and have Clockworkmod installed. Please let me know if I missed something or if I can clarify this further. Thank you to Saridnour and everyone else who worked on this.

December 1, 2011 at 6:42 AM Flag Quote & Reply

blahblah

Posts: 11

I did a Clockworkmod from ubuntu linux post here if anyone is interested too:

http://heartheecho.webs.com/apps/forums/topics/show/6684458-echo-cwm-recovery-updated-11-28-to-v1-3-?page=3

December 1, 2011 at 7:19 AM Flag Quote & Reply

Juggalogrim
Member
Posts: 2

when i put in su i get permission denied HELP!!!

December 1, 2011 at 6:30 PM Flag Quote & Reply

Scarm10
Member
Posts: 13

try rerooting, that means your permissions didnt allow superuser to be installed

make sure you have the drivers installed completely. i had to to a few reboots, just finished like 5 minutes ago

December 1, 2011 at 6:45 PM Flag Quote & Reply

Juggalogrim
Member
Posts: 2

how to install the sdk driver

 

December 1, 2011 at 7:12 PM Flag Quote & Reply

Scarm10
Member
Posts: 13

you want to goto echobykyocera.com/developers/sdk-tools . DL the setup, ndis, and adb (make sure you click the right one based on 64 bit or 32 bit OS) install the setup first, then ndis, then adb. restart you comp, plug in your phone (turn on usb debug, and put usb connect in charging only) and run Saridnours root me, just follow the on screen instructions

December 1, 2011 at 7:20 PM Flag Quote & Reply

Michael Bailey
Member
Posts: 4

Every time I download this it puts it as an internet explorer file or a music file. Does anyone know why?


December 2, 2011 at 2:47 PM Flag Quote & Reply

blahblah

Posts: 11
@Michael Bailey: Do you have a file compression program that reads ".rar" files installed? Like 7zip or winrar? http://www.7-zip.org/ http://www.win-rar.com/download.html
December 2, 2011 at 4:33 PM Flag Quote & Reply

myshtbang
Member
Posts: 2

THANK YOU SO MUCH!!!!! It worked perfectly! You wouldn't happen to know of a way to get around the error "your plan doesn't support hotspot tethering, contact your provider" (or something close to that lol) and use hotspot tethering on the Echo do you? :)

December 16, 2011 at 6:34 PM Flag Quote & Reply

dustin
Member
Posts: 1

which device driver do i need? or do i need all 4?

December 23, 2011 at 7:20 PM Flag Quote & Reply

slipmud31
Member
Posts: 2

Sgt Recon at October 13, 2011 at 11:40 PM

Hey just wondering, woulf anyone be interested in a sense 3.0, miui and Cyanogenmod7 roms for this phone?

I would love those

December 28, 2011 at 4:11 PM Flag Quote & Reply

xBL3NDxMEx
Member
Posts: 126

you need all four

--

Its Ncredible


December 29, 2011 at 4:44 PM Flag Quote & Reply

lumac
Member
Posts: 3

thanks alot.. z4root wasnt doing it. just did the one click root and worked flawlessly.. didnt take longer than 5-10 mins total.. well except for all the files you need to download, but still doesnt take long.. im a new kyocera owner, just bought it yesterday, and this website is pretty kool... helped me out :)

December 31, 2011 at 8:19 AM Flag Quote & Reply

devaundre
Member
Posts: 2

You are the man..... This was awesome

 

December 31, 2011 at 9:34 AM Flag Quote & Reply

Tman1978
Member
Posts: 1

i have all drivers installed and i dont know what to do next. im on 2.3.4 version GB. ive never rooted and have no idea about the steps. any help?

December 31, 2011 at 10:25 PM Flag Quote & Reply

X3RO
Member
Posts: 12

blahblah at December 1, 2011 at 6:42 AM

I'm an ubuntu linux user and since I didn't see anything posted yet for rooting from linux I want to throw together a rough description of what I did for any other linux users.

1) First, you need adb for linux. I got mine from the platform-tools folder in the android sdk.

2) You need adb to recognize you have your phone attached. Attach your phone to the computer with usb. Within the folder that adb is in, if you type ./adb devices and you get a line with a bunch of ???????? then you need to do this step. Otherwise if it shows a serial number you can skip this step.

For reference please see these two links

http://esausilva.com/2010/05/13/setting-up-adbusb-drivers-for-android-devices-in-linux-ubuntu/

Second post on here: http://ubuntuforums.org/showthread.php?t=1707734

Basically this is what I did:

From a terminal window type "lsusb". That should give you a line like below

Bus 002 Device 019: ID 0482:051b Kyocera Corp.

 

What you are looking for is the manufacturer id which in this case is the "0482"

Then you need to edit a file called /etc/udev/rules.d/51-android.rules (I use vi for my editor in this step)

sudo vi /etc/udev/rules.d/51-android.rules

Inside that file put:

SUBSYSTEM=="usb", SYSFS{idVendor}=="0482", MODE="0666"

Save it and then run these commands:

sudo chmod a+r /etc/udev/rules.d/51-android.rules

sudo service udev reload

./adb kill-server

./adb start-server

You can check to see if this worked by typing ./adb devices and it should now have a serial number instead of ????????.

3) Copy the following files from Saridnour's RootMe.rar file to the directory adb is in:

zergrush

Superuser.apk

 

su

busybox

4) From this point, I pretty much typed in all the lines from Saridnour's RootMe.bat file that start with adb, in order just like he has it up to and including the final reboot:

rem //////////// FINAL REBOOT ////////////

adb reboot

At that point you should be rooted. I currently am rooted and have Clockworkmod installed. Please let me know if I missed something or if I can clarify this further. Thank you to Saridnour and everyone else who worked on this.

i think this should be a stickied tutorial all by its self...... great job

--

check out my music page at http://www.facebook.com/x3ro210 ... let me know what you think

January 3, 2012 at 8:54 AM Flag Quote & Reply

Yen
Member
Posts: 3

i run 64 bit windows 7 and i have the 64 bit driver installed, the root script detects the phone connected goes through the rooting process and at the end says its successful, it did put superuser on my phone, but i do not have root access and when i do the SU +enter it will give a permission denied. I retried installing drivers and redoing the process about 3 times. Anyone know what might be going wrong?

January 11, 2012 at 7:11 PM Flag Quote & Reply

You must login to post.

+1 Us :-)

Visitor Count

Like us on Facebook

Donate to Us (For the Project :-)

My donations email is [email protected] . thank you for your contribution :)